English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   CD32 Hard Drive toolkit Lenon Lives (http://eab.abime.net/showthread.php?t=57919)

amigapd 21 February 2011 15:30

CD32 Hard Drive toolkit Lenon Lives
 
Hi,

I ve used the CD32 cd toolkit to create a cd compilation but I now want to use the hard drive version to see if it makes game loads faster and also include a zipped version on my website so that users without a cd32 can enjoy the pd compilation- I have created an archive but when I unzip it on the Amiga I cannot get the menu to load or the games to load using the start scripts.

Ideally I want the Hard drive to be on my CF card in the pcmcia slot - Can someone provide me with some pointers as to where I am going wrong.

Thanks

Anakirob 23 February 2011 11:00

Put the following text in a script and run it from the compilation directory.
Code:

Assign <disk label>: ""
Assign Fonts: <disk label>:Fonts/ ADD
Assign Libs: <disk label>:Libs/ ADD
Assign S: <disk label>:S/ ADD
Assign C: <disk label>:C/ ADD

I don't know if you've tried this already, but if you haven't then you definitely want to.
And I'm assuming that when you were making your assigns that you used the label of the disc and not CD0:, otherwise you'll have some editing to do.

Also, seeing as the HD compilation is intended for users of an actual Amiga, LHA would be preferable to ZIP.

amigapd 24 February 2011 02:41

I ve got it working sort of but have the following problems:

The menu font is wrong - the screen is dark blue background and light blue text I think and the picture images are messed up - there is no music.

To get it to work to this stage on a real amiga 1200 I ve had to change the AMS loader to the following:


FAILAT 99999

ECHO "*E[0;0H*E[J"



cf0:AMSHD

C:Avail FLUSH >NIL:
CD CF0:Games
ECHO "Executing..."
C:Execute RAM:.run

IF EXISTS RAM:AMSLoader
C:Execute RAM:AMSLoader
ENDIF

I ve also changed the start script to:

cf0:c/anticlick

C:Assign >NIL: RAD: EXISTS
IF NOT WARN
FAILAT 99999
IF NOT EXISTS RAD:OK
ECHO >RAD:OK
C:Assign T: RAM:
CD SYS:Games
C:Execute RAD:.run
C:HardReset
ELSE
C:HardReset
ENDIF
ENDIF


C:Assign Data: cf0:Data
C:Assign ENV: RAM:
C:Assign T: RAM:

C:SetPatch QUIET

IF EXISTS SYS:Splash.iff
IF EXISTS SYS:Splash
SYS:Splash
ENDIF
ENDIF

C:Copy cf0:AMSLoader RAM:
C:Execute RAM:AMSLoader

in WINUAE the pictures and colour for the menu are fine in testing mode.

UPDATE:

Have managed to get it working by adding

Assign Sys: CF0

: ) - It is so much faster loading than the cd32 cd -

amigapd 26 February 2011 01:05

Ok now have two new problems:

The menu music seems to cause the point and click games not to work (lethal Formula, Lord of Alcandria 2 and 3) - I have solved this by removing Hip from the C folder - during the AMSloader execution the file isn't found and the point and click games work - has anyone had any problems with the menu music causing games not to load?

The second issue relates to Seuck games - during the game between the SEUCK screen the compilation seems to reboot to menu in the back ground - if you press fire at this stage then you accidently load another game in the background - this second game appears between the second SEUCK title screen and the main game - as soon as the main game is playing there are no interuptions - as soon as you lose all your lives the second game makes another appearance. Has anyone experienced this?

Apart from these bugs - the compilation is working well from hard drive:

The WHDLoad games work fine
The screen shots now appear in the menu
95% of the other games work without any problems -
The HD version is a lot quicker to load both to the menu and when loading games -

I hope to make this available for download so individuals can create a CF public domain hard drive and play through the pcmcia slot on their Amiga 1200s


All times are GMT +2. The time now is 18:02.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.04028 seconds with 11 queries