English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   WarpUP - PowerPC Program Exception - Please, help! (http://eab.abime.net/showthread.php?t=94363)

jurassicman 23 September 2018 17:04

WarpUP - PowerPC Program Exception - Please, help!
 
Hello all...
I've been struggling for the last two days trying to have a working WarpOS configuration.
I've tried everything... every WarpOS configuration, every warp*.library, etc, etc... without luck... :(

In any case when I try to lunch a WarpUP program (e.g. x64.exe from VICE-WarpOS-1.22) i get a message like "PowerPC Program Exception":

https://i.imgur.com/l9zsWXA.jpg

https://i.imgur.com/aJb15CB.jpg

https://i.imgur.com/Baz6KNL.jpg

I've also tried the demo that come with warp3d and they do not work...
I even patched all the libs with the patches available here.

If anyone has an idea or can give me some tips, please do it! :)

kriz 23 September 2018 17:32

Blizzard or Cyberstorm ?

jurassicman 23 September 2018 18:19

I'm using a Blizzard Blizzard PPC. I've also run a memtest on the 256MB of RAM in order to be sure that it's not a HW issue.
The Mediator is a new Mediator TX Black and the Video Card is a new Radeon 9200 HD.

I installed Warp3D 4.2a for Mediator.

I also used BPPCFix addin on my S:Startup-Sequence the following line before the blitzkick line:

RUN >NIL: BPPCFix install Reboot

If I run a PowerPC program (the test programs for example) they work since I addedd the following ppclib emulation line on SS.

ppclibemu_install NAME LIBS:ppc.library CLOSE

I really think I've tried everything.
Initially my system hang at startup since I was loading both, PowerPC and WarpUP/WarpOS libraries but after readin all the guides I was able to start the system but I still have that error with every WarpOS program.

I've followed the instruction found here but after having done many tries... would it possible to "clean" all the mess I've probably done in order to start from scratch? How?

Hedeon 23 September 2018 18:31

Quote:

Originally Posted by jurassicman (Post 1271169)
I even patched all the libs with the patches available here.

If anyone has an idea or can give me some tips, please do it! :)

First try with the original libs, I'd say. Or did this imply you already tried that?

jurassicman 23 September 2018 18:35

Quote:

Originally Posted by Hedeon (Post 1271200)
First try with the original libs, I'd say. Or did this imply you already tried that?

To be honest I think that I've already tried everything but I am willing to try again... what libs are you talking about? warp*?

Hedeon 23 September 2018 19:04

Quote:

Originally Posted by jurassicman (Post 1271202)
To be honest I think that I've already tried everything but I am willing to try again... what libs are you talking about? warp*?

Same libs you meant by ''all'' in your post. Anyway, I think VICE 1.22 compiled for WOS doesn't work as it doens't work here either.

You said the test programs work after starting ppclib emu....are we talking about PUP or WOS test programs here?

jurassicman 23 September 2018 20:33

Quote:

Originally Posted by Hedeon (Post 1271212)
Same libs you meant by ''all'' in your post. Anyway, I think VICE 1.22 compiled for WOS doesn't work as it doens't work here either.

You said the test programs work after starting ppclib emu....are we talking about PUP or WOS test programs here?

The PUP test programs do work.
The WOS demo programs do not work.

I could try to install again all the libs but as said I've been doing it from yesterday morning and I can't see a solution.

Could this problem be caused by something else, maybe a program on my S:Startup-sequence file or a library or something else?

Cowcat 23 September 2018 21:43

Quote:

The PUP test programs do work.
The WOS demo programs do not work.
PUP lib (that is loaded from the ppc card) looks that stays there and something doesn't allow powerpc.lib (on libs/) to be loaded.

For now better remove whatever ppc command you have in S:S, look around for some ppc.datatype lurking in some place at the time you boot (like desktop background image, etc).

When you start "clean" (no ppcfix, etc) and you run a warpos program, a message should appear saying that the two libraries can't be running at the same time and ask for switch one for the other (you can't go back to PUP). You must see something like that before trying to add stuff to S:S: and go to other more complex configurations.

I would try "simpler" programs without gfx/3d card or anything (like some aga warpos stuff like quake warpos) to run, before even do it all at once.

Run Snoopdos to see what is really loaded or missed when a warpos program is called.

More edit:
What you say:
Quote:

Initially my system hang at startup since I was loading both, PowerPC and WarpUP/WarpOS libraries
mmm.....no. That could be what I said about a ppc program loading a ppc.datatype. OS 3.9 had that problem hanging the system right away. Voila, no problem when the warpos libs (powerpc.lib, warp.lib) are removed.....instead better look for those datatypes.

PUP/WOS libs can't collide per se, because there's always a message telling what is the situation.

jurassicman 23 September 2018 21:55

@cowcat
Ok, thanks... I'll try to follow your advices...
@hedeon
Thanks for your time, mate... and thanks for letting me know that Vice doesn't work there either...

Cowcat 23 September 2018 21:57

I added more to it. And don't go for "old-old" aminet warpos stuff.

jurassicman 23 September 2018 23:33

Quote:

Originally Posted by Cowcat (Post 1271244)
(...)
More edit:
What you say:

mmm.....no. That could be what I said about a ppc program loading a ppc.datatype. OS 3.9 had that problem hanging the system right away. Voila, no problem when the warpos libs (powerpc.lib, warp.lib) are removed.....instead better look for those datatypes.

PUP/WOS libs can't collide per se, because there's always a message telling what is the situation.

You are perfectly right.
I can start the OS leaving both PUP and WOS libraries if I remove the wallpaper picture, a standard jpeg file... I didn't know that it was the cause of the hang.

If I start the system without BPPCFix and with PUP/WOS libs I receive the alert message. If I click on terminate I am able to use the system and if I click on continue (or cancel, I don't remember exactly) the system hangs.

However if I click on terminate I face weird errors like a "RAMLIB program failure" when I do a normal thing like opening "AmitradeCenter" or just browsing through folders. :(

I had to put back on my Startup-Sequence the BPPCFix and ppclib emulation lines in order to have again a stable OS... that's weird I think...

As per the WarpOS programs... is there any program I can try to see if my configuration works?

DanyPPC 23 September 2018 23:36

Have you set PPC TERMINATOR variable to "2"
this is necessary on BlizzardPPC

grelbfarlk 23 September 2018 23:54

Just try the stuff in the WarpUP distribution in tools.
You might also try raising stack.
Best to start with making sure ppc.library is truly disabled. Remove ppc.library, set Terminator=2 and boot and see if you can do a version ppc.library. If you get a version back then it's not really disabled.

Also watch out for libraries you didn't know had powerpc.library components like asyncio.library or rtgmaster.library.

Some people have recommended Chucky's guide to setting up the BPPC: http://wordpress.hertell.nu/?p=18

If you don't have the WarpUP prefs in prefs, I've used this before. http://aminet.net/package/util/misc/WOSprefs does much of the same stuff.

Cowcat 24 September 2018 12:26

Quote:

I can start the OS leaving both PUP and WOS libraries if I remove the wallpaper picture, a standard jpeg file... I didn't know that it was the cause of the hang.
In reality is the "desktop background program" running just when OS is booting up: It has no time to fully load all stuff, so you can't even see the "switch message" popping out.

Quote:

If I start the system without BPPCFix and with PUP/WOS libs I receive the alert message. If I click on terminate I am able to use the system and if I click on continue (or cancel, I don't remember exactly) the system hangs.
Terminate means "disable/kill PUP lib" so warpos libs can load. Don't remember exactly about continue or cancel.......did "cancel" meant "don't remove PUP lib" ??? If it's that, warpos cannot be run and that could be a problem.

@greg talks about ppc.library -> you should not have a ppc.library in libs.

ppc.library belongs to PowerUP: Really few programs use this kernel. PUP is dead for almost two decades. Remove ppc.library (or whatever "really old" datatype of that kind). It should never be in your system libs. There are other ways to emulate PUP on top of Warpos.

Remember that still "the other" ppc.library is waiting "background" when you boot and is done automatically by the ppc cards. PPCFix removes/disables it at the time you boot.

Quote:

However if I click on terminate I face weird errors like a "RAMLIB program failure"
I never had a problem with it (increasing stack). Maybe because I had a 68040 and it was simpler than leading with 68060 libs configs at boot time.

Also, just when you start the machine you can go directly to the ppc card boot screen to see if something needs to be changed. Pressing "2" key if I remember well.....but that is another war.

Quote:

ppclibemu_install NAME LIBS: ppc.library CLOSE
ppclibemul_install :confused :confused :confused why ????

jurassicman 24 September 2018 15:08

This is the ppclibemu program I used.
http://aminet.net/package/util/libs/ppclibemu


As you can see it provides a ppc.library replacement.


I have that ppc.library in my LIBS: directory and the line "ppclibemu_install NAME LIBS:ppc.library CLOSE" in my S:Startup-Sequence but honestly I don't know if I really need it.


All this PUP/WUP thing seems to me a big mess...

Mad-Matt 24 September 2018 15:33

Unless you plan to use really old PowerUp software, you don't need to worry about setting up pplibemu. The big issue seems to be the loader for loading the emulib and there are many of them. The most compatible one I found was the one included in FroggerPPC.

If setting up with BPPCFIX to remove ppc.lib from memory then you can set Terminator off, Earlyterm off and No Patch ON for a clean WarpOS ppc system. ppclib emu is then optional if you really want to run the older software.

Hedeon 24 September 2018 15:36

In addition to Mad-Matt:

Install StackAttack and Ramlibpatch if you find yourself having a lot of RamLib crashes.

grelbfarlk 24 September 2018 23:40

Quote:

Originally Posted by jurassicman (Post 1271427)

All this PUP/WUP thing seems to me a big mess...


Maybe it's easier to think of it like this, ppc.library is some obsolete version which was replaced by a very different version called powerpc.library. Unfortunately the BlizzardPPC has an obsolete version of ppc.library in ROM which you have to take steps to manually disable. When that's done you should be able to use powerpc.library correctly. Ignore any programs that say PowerUP and get them off your system until powerpc.library is working.



Now if you just want to know if your PowerPC chip is totally hosed you can use this test disk:
http://powerup.amigaworld.de/index.php?lang=en&page=24
PPC Test Disk
Don't use any files from it, just boot it up and let it run.



This is ppc.library based so it doesn't tell you anything about what's working or not with your normal Workbench install.





AFTER powerpc.library (WarpUP) is working correctly with some real programs like Adoom and such then you might contemplate installing the powerup lib emulation you got from Aminet. There aren't very many good PowerUp applications anymore that weren't replaced by a superior WarpUP version.

drluking 25 September 2018 01:21

hello,

sorry, which are the best practices about WOS for cyberstormppc ? (read about 16.1beta better stable then 16.1final ... and correct/important ENVARC: variables to be set ? ...etc...)

and which is the best 68060.library version to use with cybervisionppc ? (46.15 ? or 46.7 ? other ? ......)

and W3D using cybervisionppc ? (version 4.2a with some particular variables to be set in ENVARC: ?)

and how to install correctly OS3.9 with Boing Bag 4 in cyberstormppc + cybervisionppc ? (Amiga ROM Update ...etc.. Is It useful to enable "maprom in fast ram" setting in early cyberstormppc menu (key ESC) while using Amiga ROM Update of boingbag2 patch ? ...etc...)

Is there a guide step by step to install all this stuff software corrctly to have a stable AmigaOS3.9 boing bag 4 with cyberstormppc+cybervisionppc ? I have seen only this one online http://wordpress.hertell.nu/?p=18 but It's for blizzardppc+bvisionppc ... not for cyberstormppc+cybervisionppc, or how to exactly adapt this guide to the cyberstormppc+cybervisionppc cards ?

THANKS !

grelbfarlk 25 September 2018 03:29

It seemed to me the 16.1 beta was somewhat less stable for me on CSPPC, and I don't know what all it fixes. I do know that it doesn't work with IFusion, so that may be relevant to somebody.

I used 46.15 of P5's 060 library. I then moved to Thor's 060.library with mmu.library-this is not really recommended unless you read the manual thoroughly, though this was more for the Sonnetlib support. Thor's 060 library makes some of the Shapeshifter Video drivers not work, but Thor includes his own (which is not quite as good as CardTrickEVD).

Pretty much the same steps in Chucky's guide apply except skip all of the Terminator and BPPCFix stuff.

There are also some Demos in WarpUP 4.0 distribution that are not in the WarpUP 5.1 update, so I would grab those out of 4.0 without installing the whole package.

With WarpUP you really want to run stackattack and ramlibpatch and remember to increase stack on applications you're trying to run.


All times are GMT +2. The time now is 15:05.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04716 seconds with 11 queries