English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.FS-UAE (http://eab.abime.net/forumdisplay.php?f=122)
-   -   Joystick help (http://eab.abime.net/showthread.php?t=98843)

AmNi 16 September 2019 12:40

Joystick help
 
Hi,


I've been trying to play various Amiga 500 games, mostly Summer and World Games. First with old xbox/ps controllers, which worked fine, but didn't have the right feeling. Then I bought some Speedlink Competition Pro USB joysticks, which I can't get to work at all. My Mac doesn't even seen them.

Now I'm trying to get a Mayflash adapter to work with some of my old Amiga/C64 joysticks. FS-UAE sees the joysticks fine, but it's still not working perfectly. Like the 'down' move is mistaken for a button press. In the settings I can map the moves and buttons, but the left move is not working. A google search led me to a github where someone posted some settings to get the Mayflash to work with fs-uae, from what I can tell due to the same issues I have. But I can't figure out where to put these settings. It says something about a default config in my documents folder, but I don't have that file.

Photon 16 September 2019 14:20

It's not here? (See the first yellow text box).

AmNi 16 September 2019 14:31

If I understand it correctly, after following the link in the yellow text box, I should have a file called default.fs-uae in my configurations folder. But my folder is empty.

Nightshft 16 September 2019 22:05

I have two different adapters - one from sinchai and on is from retrobit - both work in Windows, having all directions and the fire button mapped correctly from the start. Can you check that on a mac on the OS side? Did you try different joysticks on the adapter (just to be sure it's not - by any chance - a bad wired joystick)?

PS: IMHO the speedlink joysticks are not such a big loss because of their input lag.

AmNi 16 September 2019 22:59

Yes, I found out about the input lag, after bying, when trying to figure out why they didn't work. I will send those back. Thanks.
I tried three different old joysticks, all the same problem. Down move is considered a button press.

I'm not quite sure what you mean by checking on a Mac. In settings I went to the controllers section and then the mapping (with the photo of a gamepad controller thing). I tried mapping there, but a) not sure which ones to pick and b) the ones I did try, d-pad, wouldn't let me map the left move.

ps. This is the github post I mentioned:
https://github.com/FrodeSolheim/fs-uae/issues/210

Nightshft 17 September 2019 22:07

I just meant to first check it on the OS control settings. I find it strange that it maps incorrectly there. But I dont know more about macs or this particular adapter, sorry mate. Good luck.

AmNi 18 September 2019 12:45

I installed a joystick tester app and can see that button #13 - #16 are also some of the moves. When I then go into the Launcher and try to map the buttons in the settings, I see that some of those share the button numbers and now the 'left' move also work. So I guess that's a step, now I just have to figure out how to change those in a configuration file or something. I'm not quite sure I understand it all (especially when I can't even find the default config), but I'll will try. Thanks :D

edit: so it *is* the same problem as the poster on github (link in above post) - it got solved by adding lines to the default config. The file I don't have.
Is there anywhere else I can add those lines or change a file or something?

edit2: Found a link to download the default config. So I'll try and make it work now.

AmNi 18 September 2019 17:01

Four hours later. Well, I got so far as to get the up, down, left and right moves to work, but then the buttons doesn't work. When I then try to get the button mapped, the moves stops to work. If I change back, nothing works. And the same if I switch games.

So I think I'm gonna let it rest for now. Maybe even wait and see if the new C64 that comes in Dec is any good. It's mostly the Summer, Winter and World Games the family is going to play anyway.

Jason H 19 September 2019 22:30

Are you using one of the Mayfash Arcade sticks? I have one myself and I know there is a button to toggle Analogue/D-Pad mode. Maybe this helps.


All times are GMT +2. The time now is 00:47.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04190 seconds with 11 queries