English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.MAGE (http://eab.abime.net/forumdisplay.php?f=76)
-   -   GameBase Amiga (http://eab.abime.net/showthread.php?t=80394)

JPond 21 November 2015 16:07

GameBase Amiga
 
Just installed it and its working mostly.

Only tried a few games but Aladdin AGA doesn't seem to run. I get the cheat screen then it stops loading and I get multi-colored lined screen. Pressing anything it goes to a full colored screen (different each time) loads for a second then goes back to not loading and multi-colored again.

Secondly, i've installed DeliPlayer. Configured it in GameBase however when I click on play music I get an error saying "Invalid procedure call or argument."

And finally WHDload. I've seen it around but since KillerGorilla's website that I need to get the ready-made installers from is dead i'm unsure about how to add it in.

Any help that could be given would be great.

Belgarath 22 November 2015 10:29

Wow a GB Amiga question..hmm let's see.

One of the problems I personally found is that compatibility with the newer winuae's is somewhat broken, so whilst every game worked once they definitely don't all work now.
Have you tried any other AGA games?

Deliplayer could be a tricky one, you've not mentioned what OS you're using? People have had problems with it under Windows 7 (it works for me but the volume always starts off at 0 for some reason). In GB Amiga the filename for the music player should be yourpath\deli.exe and the command line should be %musicfile%
There are other music players but I've had mixed results with both XMPlay and BZR Player, XMPlay plays a lot but not all, BZR plays some that XMP won't but actually crashes on others.

As for WHDLoad, try looking on the gamebase 64 forum, there's some very helpful people on there and someone may have made the whdload pack available.

JPond 22 November 2015 12:16

Yeah it was the only one I found front end wise, as I tried setting it up myself but some games ran, others didn't so I just though ill use a front end.

I didn't but I just did try it and it seems all AGA versions do the same thing. All non AGA games seem to work fine though. Aside from Monkey Island which says insufficient memory.

Sorry i'm on Windows 10 Pro. I had to set DeliPlayer as to run as admin, otherwise it wouldn't work. I've got Player Path as D:\Emulation\Amiga\DeliPlayer2\deli.exe command line is %musicfile%

Didn't even know of the gamebase 64 forum, just came here as thats what the guide said to do, thanks for that.

Belgarath 22 November 2015 12:21

Never tried deliplayer under windows 10, it's probably that which is causing the problem.

as for the aga games, are you sure you've got the correct kickstart rom?

JPond 22 November 2015 13:41

Most likely, though I can launch the main program of it fine, its just when GameBox tried to launch it I get an error.

The kickstarter for the A1200 one I have is Kickstart v3.1 rev 40.68 (1993)(Commodore)(A1200) I assume that's the one your talking about.

Belgarath 22 November 2015 14:02

That's the one

go to an aga game, press f2 and try adding these lines in (if they're not there already).
It doesn't matter where the lines go

cycle_exact=true
chipset_compatible=A1200

JPond 22 November 2015 15:08

That didnt work, still does the same thing. Heres the exact coding for Aladdin AGA:

kickstart_rom=v3.1 A1200
nr_floppies=3
floppy0type=0
floppy1type=0
floppy2type=0
floppy3type=-1
immediate_blits=true
ntsc=false
chipset=AGA
collision_level=playfields
fastmem_size=4
bogomem_size=0
chipmem_size=4
cpu_speed=max
finegrain_cpu_speed=max
cpu_type=68020
cpu_compatible=false
cpu_cycle_exact=false
blitter_cycle_exact=false
statefile=savestates\Aladdin (AGA).uss
cycle_exact=true
chipset_compatible=A1200

Belgarath 22 November 2015 16:45

delete that entirely and try this one (btw which version of winuae are you using?)

kickstart_rom=v3.1
nr_floppies=2
floppy0type=0
floppy1type=0
floppy2type=-1
floppy3type=-1
immediate_blits=false
ntsc=false
chipset=AGA
collision_level=playfields
fastmem_size=0
bogomem_size=0
chipmem_size=4
cpu_speed=real
cpu_model=68020
cpu_compatible=false
cycle_exact=true
chipset_compatible=A1200
cpu_24bit_addressing=false
statefile=savestates\Aladdin (AGA).uss

JPond 22 November 2015 18:08

I'm using WinUAE 3.2.0 (2015.11.11) 64-bit. (I have also tried the 32 bit version and still got the same results.)

When I replace it using your entry and try to launch Aladdin I get "The selected system ROM requires a 68020 with 32-but addressing or 68030 or higher CPU."

Belgarath 27 November 2015 21:33

I've put a replacement config file in the zone, try replacing your existing one with the new one and let me know how you get on.

JPond 29 November 2015 13:27

I dont have permission to enter the zone yet.

Belgarath 29 November 2015 17:39

http://eab.abime.net/faq.php?faq=vb_...ezone_faq_item

JPond 29 November 2015 21:20

Ok downloaded it replaced it and still get "The selected system ROM requires a 68020 with 32-but addressing or 68030 or higher CPU."

Belgarath 29 November 2015 23:23

1 Attachment(s)
The gemus script probably needs replacing as well.

Put this in the scripts directory, make sure in gamebase in gemus menu you edit the config for your chosen emulator and tell it to use the new script.

If it still doesn't work...wait til Christmas, new version out then.

JPond 30 November 2015 10:30

Yeah it still doesnt work, so guess i'll be waiting until Christmas then. Thanks for all your help Belgarath anyway.

Belgarath 30 November 2015 11:10

Have you got kickstart 3.0? If you have then try changing to
kickstart_rom=v3.0

JPond 30 November 2015 16:23

I don't have that one I don't think. How is Amiga Forever? Is it any better, or don't you use that?

Belgarath 30 November 2015 19:14

I wouldn't touch Amiga Forever with a 10ft barge pole.

JPond 30 November 2015 23:09

That bad then? I'll hold off then and wait for the new GameBase version. Hopefully it will work ok then.


All times are GMT +2. The time now is 11:13.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.05287 seconds with 11 queries