English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.FS-UAE (http://eab.abime.net/forumdisplay.php?f=122)
-   -   Two general questions (http://eab.abime.net/showthread.php?t=105272)

Darque420 05 January 2021 19:36

Two general questions
 
I'm using FS-UAE on my Raspberry Pi 400. Version 2.8.4

That's the only version that's in the package manager that will automatically install. I'm trying to figure out how/if I can install the newest Linux version, 3.0.5

Anyway, on that version, I have a few questions. First is how to add box art/screenshots to the bottom of the program for each game. I swear I did it on the Windows version, but I forget how I did it.

Secondly, how do I do WHDLoad games in 2.8.4? I have a bunch of .lha files in the Hard Drives folder. I already chose Update File Database from the menu. It scanned the folder. But...it didn't automatically configure the stuff like I'm assuming it is supposed to do. From what I've read online.

I assumed that after updating the file database, it would automatically configure each game and list them under Configs/Games. But it doesn't. It just scans the folder.

I've seen a few Youtube videos on what to do, but nothing is 100% complete. Will FS-UAE 2.8.4 see the lha files, or do they have to be in zip file format? I think they need to be run under Amiga 1200 with 8MB of RAM...but other than that, I don't know what to do on the har drives page of the program.

So, do they need to be in zip format? Can I change the lha to zip? or do I need to actually zip the lha file?

Thanks. Any simple english tutorial would be of great help..

Thanks.

FrodeSolheim 05 January 2021 22:39

Hi,

First of all, I've gotten myself a Raspberry Pi 400 and like it a it. So I'm (probably) going to make sure FS-UAE runs better on this system going forward. I've already done some adaptions for RPI4 for FS-UAE 4.0, and it is looking promising. So, I will probably release official builds for this system in the future.

In the meantime, I guess you need to compile a newer version yourself if you want to.

Regarding WHDLoad games and the file database issue. I'm guessing that the problem is the you don't have the lhafile python library for reading .lha files. If I recall correctly, it is not included in Debian (which RPI4 gets its packages from). Again, right now, you might have to install that yourself if you want it. If pip3 is installed, it might be sufficient to run
pip3 install lhafile
. But when/if I provide official packages for RPI4 going forward, that should not be needed.


All times are GMT +2. The time now is 04:28.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.07400 seconds with 11 queries