English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   Member Introductions (http://eab.abime.net/forumdisplay.php?f=104)
-   -   Hello, and questions about getting an A3000 up again (http://eab.abime.net/showthread.php?t=92163)

hth313 07 May 2018 00:41

Hello, and questions about getting an A3000 up again
 
Just thought that I should introduce myself. I am a swedish expat living in Canada since 3 years.

I started with an Amiga 500 around 1987-1988, went into programming and ended with an Amiga 3000 in the early nineties. I was a registered developer back then. I grew fed up with the file system corruptions and "upgraded" the Amiga 3000 to run NetBSD. It served that purpose for some years, but eventually I moved on to Sun Sparc and Mac OS X.

I kept the A3000 around (started it from time to time to see that it worked, replaced the clock battery), but did not really use it.

When I moved overseas, I brought it with me and now it was time for a clock battery change again. I looked around the internet and found that the Amiga is very much alive! I can even replace the broken SCSI drive (I went through several during the years) with an SD card!

However, the machine seems to have trouble reading (the by now very old) floppies and the HD is rattling with loose parts inside. No secondary storage media works, but the machine starts up at least.

What is the best way to approach this? I am thinking of getting an SCSI2SD and prepare a system on a vitual box PC running a virtual Amiga and create the HD image. How can I get suitable ROM images, Workbench and such for this environment?

The machine has a kickstart 1.4, and I prefer to keep it that way. I hope that I can put a 3.1 system on it and do not mind paying for the service of getting new solid images, if needed.

Håkan

chip 07 May 2018 03:24

Welcome to the forum hth313 :)

Jope 07 May 2018 14:19

Clean the read/write heads, lube the head carriage rails.

The diskchange / rw switches also corrode in these, dismantling them for cleaning is annoying, sometimes it's enough to spray a very tiny bit of electronics corrosion cleaner in beside the stem and move the switch up and down to get some of the corrosion to move.

hth313 11 May 2018 04:40

Thanks!

I cleaned the heads on the floppy drive and it helped a bit. It still has severe trouble to read floppies but can often manage after several trials, more on that further down.

I managed to get the machine to read the 2.04 superkickstart (the only kickstart floppy I found so far). I then had the installer partition an 18GB Barracuda and installed an 2.04 AmigaOS on it (luckily I have several copies of those floppies). So the machine is up!

I found a floppy with AS225 TCP/IP, but no A2065 drivers. The driver was found on an Envoy floppy. I do not know how complete the AS225 floppy is. It seemed to have been used to configure the local network I had some 27 years ago and with some tweaking I managed to get it the A3000 up on my current local network.

Today I rebuilt the power supply for 110V and mounted an nfs partition so that I could transfer some files from aminet.

Great progress in other words!

There are a couple of issues though. The internal df0: floppy does not seem so healthy, it frequently have read problems. I tried an external third party floppy drive that is even older and it chewed along without any issues. I did not use the internal floppy much in the past, mostly the HD. Is there something to be done about it or should I look for a replacement?

I worry a bit over the HD. The installer just partitioned it for me and I have no idea what it did and if the 18GB size is a problem.
When the machine starts the HD light goes on for many seconds (like 5+) and no sound apart from spinning, but when it finally goes to work and do things, it really happens rapidly.

The machine is without any clock battery at the moment. I consider to just try and set the time from internet, if that is possible or I maybe will get a battery for it later.

It was so cool to fetch files over the local network, just sweep in a floppy image in a couple of seconds. I know, only 10MB/s but not too bad for a ~27 year old machine that I had no idea if I could get it up a few days ago.

Then I have to figure out how to get filename completion in the shell. It is driving me half crazy, but at least it has command history...

Håkan

Hewitson 11 May 2018 14:14

Quote:

Originally Posted by hth313 (Post 1240054)
Then I have to figure out how to get filename completion in the shell.

http://aminet.net/package/util/shell/KingCON_1.3 ;)

hth313 17 May 2018 02:25

Quote:

Originally Posted by Hewitson (Post 1240137)

I found my original floppies for WShell (2.0 seems to be the latest I have) that I bought back in the days. Though I cannot figure out how to get file completion enabled with it. It has FComp that I enabled, but it does not want to work.

hth313 17 May 2018 08:08

I managed to get WShell going after studying the manual further. It needs to have the DisplayHandler activated (DHOpts CNC: ). This fixed command completion and added a scrollbar to the shell, very nice!

However, as I run interlace (the A3000 has the flicker fixer built in), the vertical scroll bars are very fat compared to the horizontal ones. Is there a way to change this?

I also have a Retina BLT Z3 board in my machine which I have only used with NetBSD in the past. Is it a good idea to activate it? I do not like moving the monitor cable back and forth, but as I have had little luck running games so far on this machine, maybe it should go into productivity only. I suspect programs that opens their own screens will appear on the built in graphics in this case, forcing me to move the cable?


All times are GMT +2. The time now is 18:18.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.03946 seconds with 11 queries