English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinFellow (http://eab.abime.net/forumdisplay.php?f=28)
-   -   WinFellow v0.5.7 released (http://eab.abime.net/showthread.php?t=90051)

carfesh 02 January 2018 17:26

WinFellow v0.5.7 released
 
We are proud to announce the release of a new WinFellow version. Compared to the earlier version 0.5.6, the following changes are included in this build:

Bug fixes:
  • floppy code was updated to use a track limit > 80; it will output random data beyond track 80 - fixes Outrun/The Games: Summer Edition; also added missing checks for disabled drives, fixing Winter Olympics 94
  • fixed a bug where unexpected pixel format flags besides RGB stopped DirectDraw initialization
  • several bugs in the screenshot code were fixed; standalone screenshots were not saved correctly in D3D mode, and used with Amiga Forever raw screenshots were missing screen areas due to faulty initialization of the internal clipping areas
  • fixed screen area mismatch when Amiga Forever region/size settings are both set to auto; auto clipping is still not supported
  • CPU instruction fixes:
    • fixed a signed bug in 64-bit division
    • minor timing adjustment for btst
  • CIA event counter changes according to documentation
  • the project files were updated to Visual Studio 2017

Please see the included file ChangeLog.txt for a full list of changes, including minor bug fixes which are not listed above.

The release can be found here:

https://github.com/petschau/WinFellow/releases

Marcy 04 January 2018 00:02

Hello, I really like WinFellow a lot (since the very first DOS version), though I still wonder, if you ever change WinFellow, so that HDD boot with Kickstart 1.3 is possible?

Best regards,
Marcy

carfesh 04 January 2018 09:42

Hi Marcy,

Petter has been working for quite a while now on what we call RDB support. That development happens in a separate branch on GitHub, which is a way for us to develop and test new features separately from the main emulator releases. We try out new features in branches, and once they seem to work ok we merge them into the main emulator branch from which we build releases.

So that feature cannot be tested in the recently released version, but there are tests going on at our end and in that test version it is already possible to boot from a HDD with Kickstart 1.3.

It is still a work in progress though, so sadly I cannot tell you anything definitive regarding a timeline.

Marcy 04 January 2018 23:21

Hi carfesh,

just wanted to know, if my voice was heard. I will continue to patiently wait for HDD Boot with Kickstart 1.3 and may be surprised once :)

Regards,
Marcy

Schlachtwerk 14 January 2018 03:32

Mouse will not work here anymore.

carfesh 14 January 2018 11:13

@Schlachtwerk, can you please provide some more details? Where exactly does the mouse not work, can you provide an example configuration and a logfile please?

Schlachtwerk 14 January 2018 14:11

I habe deletet all, sorry, but i have bootet up the the Workbench 3.1 Install disk and cant move the mouse on the amiga side, only mouse move that was possible was with keyboard. In the Prefs was all allrigt with the Ports for mouse.

Win10 Pro x64 all updates installed
Phenom 2 x4 965 Black Edition
12GB Ram
Geforce GTX 770

I will test it again later again.

Schlachtwerk 14 January 2018 15:55

Okay my fault, why i must press after start f12 to aktivate mouse ?

carfesh 14 January 2018 16:15

Normally you shouldn't have to; input devices are captured when starting an emulation session and can be released/recaptured by pressing F12.

Did you maybe use Alt-Tab to exit the emulation session? You are using the current version (0.5.7)?

Schlachtwerk 14 January 2018 19:07

Yes using the last build version

Cobe 27 June 2018 16:55

I like WinFellow, its simplicity and the fact it runs fast on old pcs. I test it from time to time.

It seems that it doesn't like the way Blitz Basic handle sprites. Everything I compile with Blitz Basic has either thrashed sprites, artifacts, straps, wrong colors, flickering or invisible sprites while on real Amiga and WinUAE they are displayed correctly.

Would you look into this? I could send you examples.

carfesh 27 June 2018 17:03

Quote:

Originally Posted by Cobe (Post 1250774)
It seems that it doesn't like the way Blitz Basic handle sprites. [...]
Would you look into this? I could send you examples.

Hi Cobe,

improving this area is already on our todo list; there has been an ongoing effort to implement a more exact graphics emulation for some time now, but it is sadly still a work in progress and not ready yet for testing. Display of sprites in certain scenarios is heavily impacted by this. It never hurts to have an additional test case though, so thanks for letting us know!

sketaful 21 September 2018 01:02

Oh, nice to see WinFellow is alive and kicking. Never really used it but think I have to try it now. Fellow was my prefered emu when it came to that or uae, but after "win" was added I got stuck on WinUAE.

Will be interesting to try it out now. And again. Nice to see you're alive :D


All times are GMT +2. The time now is 05:42.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.04638 seconds with 11 queries