View Full Version : Minimum requirements for MFMWarp?
28 October 2005, 06:13
It looks as if MFMWarp is NOT made for A500 or A2000 machines with KS 1.3.
Even on KS 2.04 it does not work, it just DIES.
mfmwarp read ram:test.mfm unit 0 low 0.0 high 39.1
outputs "programmed by Ferox 1995" then it dies TOTALLY.
Can anyone explain why?
(yes I tested on REAL A1000 with 512K internal RAM + 1 M sidecar, thus 1.5M in total!)
As the source code is available, there might be only a little fix needed for 1.3/2.04 compatibility. For me, this tool is just unusable at the moment. :bash
28 October 2005, 07:11
Have you got XPK installed correctly? Why exactly do you want to use MFMWarp? Can you try WWarp instead? (Although it is WB2+ only from memory)
28 October 2005, 20:22
Well, lemme answer ALL of your questions in sequence ...
1) I have a game (non-WHD) which NomadWARP does NOT work with, unlike all other games I tried. (Software error - task held)
Pity that NOMAD is not around here and I can't just send some debug info to him. :(
Test-ripping the first half of the disk with Toni's rawread revealed that there are EMPTY tracks on the NDOS game disk which seem to confuse NomadWARP. (Track 37 ++)
2) XPK ... well, I tried to copy xpkmaster.library to LIBS: but this did not seem to be enough. :rolleyes
What is the minimum must-have for XPK then? (xpkmaster.library AND ...?)
3) You were guessing right: I cannot use WWarp, either. Tried to copy it over to my miggy and got this:
Sorry, WWarp requires a 68020 or better.
Very nice. Well, maybe Wepl has some older version in the depths of his archives which will still work with 68000 machines? The current one definitely doesn't.
@Wepl:: could you PLEASE include this requirement in your Readme.txt, too? In current state, it is nowhere to be seen. So that people who do not fulfil this requirement will not be downloading WWarp in vain!
Thanks for the reply, anyway.
28 October 2005, 22:03
1. NOMADWarp is buggy - fullstop. Avoid. The packer/unpacker in it is horrendous and crashes regularly.
2. Why not just run the install script to install it? Have you got all the XPK sublibs in LIBS: aswell?
3. It is extremely unlikely Wepl has an old version of WWarp. It was started after WB2 came out and making stuff work with 1.3 is often a chore. None of the cool stuff like command line args are easily supported in 1.3.
You didn't actually say why you need to use a warper aswell. Can't you use the CAPS dumping tools or use WWarp on a different Amiga or something?
28 October 2005, 23:18
The install script requires installer >= 49.2, which to my knowledge is NOT available for 1.3.
I checked the aminet versions; V37+!
BTW: CAPS tools are for 68020, too. :)
vBulletin® v3.7.0, Copyright ©2000-2013, Jelsoft Enterprises Ltd.